Xcode Jetfire issue

Back to Bug Reports
The issue in this thread has been resolved.

I am not sure if this goes in Bug Reports..

Fuse 0.35, Mac Sierra Anyway, so I just installed Fuse in a new Mac and everytime I try to build (even an empty project) to iPhone I get the following error

dyld: Library not loaded: @rpath/Jetfire.framework/Jetfire
  Referenced from: /var/containers/Bundle/Application/5DDF148C-D276-4DDC-977F-8FC95B52FD31/test.app/test
  Reason: no suitable image found.  Did find:
    /private/var/containers/Bundle/Application/5DDF148C-D276-4DDC-977F-8FC95B52FD31/test.app/Frameworks/Jetfire.framework/Jetfire: code signing blocked mmap() of '/private/var/containers/Bundle/Application/5DDF148C-D276-4DDC-977F-8FC95B52FD31/test.app/Frameworks/Jetfire.framework/Jetfire'
(lldb) 

I know it's not fuse because nothing fails on my iMac, any ideas anyone?

Hi, i have same issue .. but this your solution don't helped me :( I have do this steps: > Click on Product -> Clean (or CMD-Shift-K)

Or by manually cleaning the Xcode setting files:

rm -rf "$(getconf DARWIN_USER_CACHE_DIR)/org.llvm.clang/ModuleCache"
rm -rf ~/Library/Developer/Xcode/DerivedData
rm -rf ~/Library/Caches/com.apple.dt.Xcode

I have also completely reinstall Fusetools .. but still the same issue :( I use now 0.36 (build 11565) And it was builded with this command:

fuse build --force -v -adebug --target=iOS --run

file

have you tried uno clean? If so, then perhaps upload the project so Fuse can see what's wrong with it. Although, since .36 is not official yet I don't know if they will be able to help (yet)

Yes i have tried also uno clean. But what i find out now is, that application working correctly in iPhone Simulator and application run in simulator without issue. But when i try it on my iPhone .. then i get on start of my app occurs this error:

dyld: Library not loaded: @rpath/Jetfire.framework/Jetfire
  Referenced from: /var/containers/Bundle/Application/801B553B-2A35-46D3-873C-A5D6DF3FE4B0/my.app/my
  Reason: no suitable image found.  Did find:
	/private/var/containers/Bundle/Application/801B553B-2A35-46D3-873C-A5D6DF3FE4B0/my.app/Frameworks/Jetfire.framework/
Jetfire: code signing blocked mmap() 
of '/private/var/containers/Bundle/Application/801B553B-2A35-46D3-873C-A5D6DF3FE4B0/my.app/Frameworks/Jetfire.framework/Jetfire'

And on the screenshot you can see the place, on which stop execution of my app, when i starting it on my iPhone. I tried it on 2 different iPhone (iPhone 6 and iPhone 5C). The result is still same.

file

I have exactly the same issue... Works fine on simulator but crash on device while trying to load Jetfire lib (it seems to be). I'm using XCode Version 8.3.2 (8E2002) on MacOS 10.12.4 (16E195). I've created a tiny and empty project using FuseDashboard. Thank you for your Help.

Solution: The certificate "Apple Worldwide Developer Relations Certification Authority" was set to "Always Trust" in the keychain. I had to set it back to "Use System Default" in order to make this work.

  • Select Keychain "System"
  • Select Category "Certificates"
  • Then select certificate "Apple Worldwide Developer Relations Certification Authority" -> Get Info -> Trust -> When using this certificate: "Use System Default"
Post Stats
  • 7
    replies
  • 1016
    views
  • 3
    users
Frequent Posters